summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer Krum <nibz@spencerkrum.com>2016-06-21 16:36:44 -0700
committerSpencer Krum <nibz@spencerkrum.com>2016-06-21 23:52:59 -0700
commit1348e723d218c40d7c4bac5a53b23ddd2a8d1234 (patch)
tree9014d9aab27d1cb074d3976e8d50ad4d7fabf2e7
parent036f800233290b37a62318c555e49ca47f3f9ff2 (diff)
Use new infra_spec_helper for gem dependencies
Notes
Notes (review): Code-Review+2: Joshua Hesketh <joshua.hesketh@rackspace.com> Workflow+1: Joshua Hesketh <joshua.hesketh@rackspace.com> Verified+2: Jenkins Submitted-by: Jenkins Submitted-at: Wed, 22 Jun 2016 07:17:03 +0000 Reviewed-on: https://review.openstack.org/332524 Project: openstack-infra/puppet-ethercalc Branch: refs/heads/master
-rw-r--r--Gemfile36
1 files changed, 4 insertions, 32 deletions
diff --git a/Gemfile b/Gemfile
index 42a85da..e350f81 100644
--- a/Gemfile
+++ b/Gemfile
@@ -1,37 +1,9 @@
1source 'https://rubygems.org' 1source 'https://rubygems.org'
2 2
3group :development, :test do 3group :development, :test, :system_tests do
4 gem 'puppetlabs_spec_helper', :require => false 4 gem 'puppet-openstack_infra_spec_helper',
5 5 :git => 'https://git.openstack.org/openstack-infra/puppet-openstack_infra_spec_helper',
6 # Pin google-api-client after it released a ruby 2.0 only version 6 :require => false
7 gem 'google-api-client', '0.9.4'
8
9 gem 'metadata-json-lint'
10 # This is nice and all, but let's not worry about it until we've actually
11 # got puppet 4.x sorted
12 # gem 'puppet-lint-param-docs'
13 gem 'puppet-lint-absolute_classname-check'
14 gem 'puppet-lint-absolute_template_path'
15 gem 'puppet-lint-trailing_newline-check'
16
17 # Puppet 4.x related lint checks
18 gem 'puppet-lint-unquoted_string-check'
19 # Disable it because we use empty string checks
20 #gem 'puppet-lint-empty_string-check'
21 gem 'puppet-lint-leading_zero-check'
22 gem 'puppet-lint-variable_contains_upcase'
23 gem 'puppet-lint-spaceship_operator_without_tag-check'
24 gem 'puppet-lint-undef_in_function-check'
25
26 if puppetversion = ENV['PUPPET_GEM_VERSION']
27 gem 'puppet', puppetversion, :require => false
28 else
29 gem 'puppet', '~> 3.0', :require => false
30 end
31end
32
33group :system_tests do
34 gem 'beaker-rspec', :require => false
35end 7end
36 8
37# vim:ft=ruby 9# vim:ft=ruby