summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNguyen Van Trung <trungnv@vn.fujitsu.com>2018-05-24 00:02:49 +0700
committerNguyen Van Trung <trungnv@vn.fujitsu.com>2018-05-24 14:22:47 +0700
commitfa4f09575961062083b92d905f4011c8a9e08e24 (patch)
treeca0acaaa67a7403419a2511ffb2fa65049cdb754
parentad0cbe99be87694f08013827974c51849cece58b (diff)
Fix incompatible requirements
A lot of packages in lower-constraints.txt and requirement.txt must change to suitable version. Which raised fail in following logs: Validating requirements.txt Validating test-requirements.txt Validating lower constraints of requirements.txt Package u'oslo.log' is constrained to 3.37.0 which does not match the minimum version specifier 3.36.0 in requirements.txt Package u'paramiko' is constrained to 2.4.1 which does not match the minimum version specifier 2.0.0 in requirements.txt Package u'setuptools' is used in requirements.txt but not in lower-constraints.txt Package u'pbr' is constrained to 3.1.1 which does not match the minimum version specifier 2.0.0 in requirements.txt Validating lower constraints of test-requirements.txt Package u'sphinx' is constrained to 1.6.5 which does not match the minimum version specifier 1.6.2 in test-requirements.txt Package u'coverage' is constrained to 4.5.1 which does not match the minimum version specifier 4.0 in test-requirements.txt Package u'oslotest' is constrained to 3.3.0 which does not match the minimum version specifier 3.2.0 in test-requirements.txt Package u'openstackdocstheme' is constrained to 1.20.0 which does not match the minimum version specifier 1.18.1 in test-requirements.txt Package u'doc8' is constrained to 0.8.0 which does not match the minimum version specifier 0.6.0 in test-requirements.txt Package u'reno' is constrained to 2.7.0 which does not match the minimum version specifier 2.5.0 in test-requirements.txt Package u'testrepository' is constrained to 0.0.20 which does not match the minimum version specifier 0.0.18 in test-requirements.txt Package u'testscenarios' is constrained to 0.5.0 which does not match the minimum version specifier 0.4 in test-requirements.txt Package u'testtools' is constrained to 2.3.0 which does not match the minimum version specifier 2.2.0 in test-requirements.txt *** Incompatible requirement found! *** See http://docs.openstack.org/developer/requirements ERROR { "delta": "0:00:09.290821", "end": "2018-05-23 16:24:17.040257", "failed": true, "rc": 1, "start": "2018-05-23 16:24:07.749436" } Change-Id: I5bcc2b3523c30126e88c0396a3ea080a70bb66bd
Notes
Notes (review): Code-Review+2: yolanda.robla <yroblamo@redhat.com> Code-Review+2: Dmitry Tantsur <divius.inside@gmail.com> Workflow+1: Dmitry Tantsur <divius.inside@gmail.com> Verified+2: Zuul Submitted-by: Zuul Submitted-at: Sun, 27 May 2018 11:05:26 +0000 Reviewed-on: https://review.openstack.org/570236 Project: openstack/bifrost Branch: refs/heads/master
-rw-r--r--lower-constraints.txt23
-rw-r--r--test-requirements.txt2
2 files changed, 13 insertions, 12 deletions
diff --git a/lower-constraints.txt b/lower-constraints.txt
index edb6a4b..d069209 100644
--- a/lower-constraints.txt
+++ b/lower-constraints.txt
@@ -6,10 +6,10 @@ bcrypt==3.1.4
6certifi==2018.1.18 6certifi==2018.1.18
7cffi==1.11.5 7cffi==1.11.5
8chardet==3.0.4 8chardet==3.0.4
9coverage==4.5.1 9coverage==4.0
10cryptography==2.1.4 10cryptography==2.1.4
11debtcollector==1.19.0 11debtcollector==1.19.0
12doc8==0.8.0 12doc8==0.6.0
13docutils==0.14 13docutils==0.14
14dulwich==0.19.0 14dulwich==0.19.0
15extras==1.0.0 15extras==1.0.0
@@ -30,19 +30,20 @@ mox3==0.25.0
30msgpack==0.5.6 30msgpack==0.5.6
31netaddr==0.7.19 31netaddr==0.7.19
32netifaces==0.10.6 32netifaces==0.10.6
33openstackdocstheme==1.20.0 33openstackdocstheme==1.18.1
34os-client-config==1.29.0 34os-client-config==1.29.0
35oslo.config==5.2.0 35oslo.config==5.2.0
36oslo.context==2.20.0 36oslo.context==2.20.0
37oslo.i18n==3.20.0 37oslo.i18n==3.20.0
38oslo.log==3.37.0 38oslo.log==3.36.0
39oslo.serialization==2.25.0 39oslo.serialization==2.25.0
40oslo.utils==3.36.0 40oslo.utils==3.36.0
41oslotest==3.3.0 41oslotest==3.2.0
42paramiko==2.4.1 42paramiko==2.0.0
43pbr==3.1.1 43pbr==2.0.0
44pep8==1.5.7 44pep8==1.5.7
45pyasn1==0.4.2 45pyasn1==0.4.2
46setuptools===21.0.0
46pycparser==2.18 47pycparser==2.18
47pyflakes==0.8.1 48pyflakes==0.8.1
48Pygments==2.2.0 49Pygments==2.2.0
@@ -54,7 +55,7 @@ python-mimeparse==1.6.0
54python-subunit==1.2.0 55python-subunit==1.2.0
55pytz==2018.3 56pytz==2018.3
56PyYAML==3.12 57PyYAML==3.12
57reno==2.7.0 58reno==2.5.0
58requests==2.18.4 59requests==2.18.4
59requestsexceptions==1.4.0 60requestsexceptions==1.4.0
60restructuredtext-lint==1.1.3 61restructuredtext-lint==1.1.3
@@ -64,9 +65,9 @@ snowballstemmer==1.2.1
64Sphinx==1.6.5 65Sphinx==1.6.5
65sphinxcontrib-websupport==1.0.1 66sphinxcontrib-websupport==1.0.1
66stevedore==1.28.0 67stevedore==1.28.0
67testrepository==0.0.20 68testrepository==0.0.18
68testscenarios==0.5.0 69testscenarios==0.4
69testtools==2.3.0 70testtools==2.2.0
70traceback2==1.4.0 71traceback2==1.4.0
71unittest2==1.1.0 72unittest2==1.1.0
72urllib3==1.22 73urllib3==1.22
diff --git a/test-requirements.txt b/test-requirements.txt
index 49f1d85..6c3dbc4 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -7,7 +7,7 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
7coverage!=4.4,>=4.0 # Apache-2.0 7coverage!=4.4,>=4.0 # Apache-2.0
8doc8>=0.6.0 # Apache-2.0 8doc8>=0.6.0 # Apache-2.0
9reno>=2.5.0 # Apache-2.0 9reno>=2.5.0 # Apache-2.0
10sphinx!=1.6.6,!=1.6.7,>=1.6.2 # BSD 10sphinx!=1.6.6,!=1.6.7,>=1.6.5 # BSD
11openstackdocstheme>=1.18.1 # Apache-2.0 11openstackdocstheme>=1.18.1 # Apache-2.0
12oslotest>=3.2.0 # Apache-2.0 12oslotest>=3.2.0 # Apache-2.0
13testrepository>=0.0.18 # Apache-2.0/BSD 13testrepository>=0.0.18 # Apache-2.0/BSD