summaryrefslogtreecommitdiff
path: root/devstack
diff options
context:
space:
mode:
authorZuul <zuul@review.openstack.org>2018-01-16 14:26:25 +0000
committerGerrit Code Review <review@openstack.org>2018-01-16 14:26:25 +0000
commit4795ef87a87ac75830af97888908b3a9487e7f3b (patch)
tree44b02d1d759872210a25d15976054cc241a15b73 /devstack
parent85e277ce195712f24d09d7b7482dfdebefbefb6b (diff)
parent84068e1526761de7fab1ddd946c3f6f2bdaf7b6a (diff)
Merge "Allow all versions of Fedora"
Diffstat (limited to 'devstack')
-rw-r--r--devstack/lib/ceph9
1 files changed, 7 insertions, 2 deletions
diff --git a/devstack/lib/ceph b/devstack/lib/ceph
index b371a1b..666f4dc 100644
--- a/devstack/lib/ceph
+++ b/devstack/lib/ceph
@@ -268,10 +268,15 @@ function _undefine_virsh_secret {
268 268
269# check_os_support_ceph() - Check if the OS provides a decent version of Ceph 269# check_os_support_ceph() - Check if the OS provides a decent version of Ceph
270function check_os_support_ceph { 270function check_os_support_ceph {
271 if [[ ! ${DISTRO} =~ (trusty|xenial|jessie|sid|f24|f25|rhel7) ]]; then 271 if [[ ! ${DISTRO} =~ f[0-9][0-9] ]]; then
272 # Assume all versions of Fedora are fine as of 2018.
273 return
274 fi
275
276 if [[ ! ${DISTRO} =~ (trusty|xenial|jessie|sid|rhel7) ]]; then
272 echo "WARNING: your distro $DISTRO does not provide \ 277 echo "WARNING: your distro $DISTRO does not provide \
273 (at least) the Firefly release. \ 278 (at least) the Firefly release. \
274 Please use Ubuntu Trusty or Fedora 24 (and higher)" 279 Please use Ubuntu Trusty or Fedora 27 (and higher)"
275 if [[ "$FORCE_CEPH_INSTALL" != "yes" ]]; then 280 if [[ "$FORCE_CEPH_INSTALL" != "yes" ]]; then
276 die $LINENO "If you wish to install Ceph on this distribution \ 281 die $LINENO "If you wish to install Ceph on this distribution \
277 anyway run with FORCE_CEPH_INSTALL=yes, \ 282 anyway run with FORCE_CEPH_INSTALL=yes, \