summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Pasquier <spasquier@mirantis.com>2017-03-29 10:12:46 +0200
committerSimon Pasquier <spasquier@mirantis.com>2017-03-29 10:12:46 +0200
commita90c6cc9b74eeb6ef1f41900f71a5ef023674cc0 (patch)
treeaf39c120b507bab0e545566e762549c9ff0ce59f
parentb5a12ffbfa4ce1c482969c2d8f2948e416263d32 (diff)
Fix Puppet tests againHEADmaster
Notes
Notes (review): Code-Review+2: Simon Pasquier <spasquier@mirantis.com> Workflow+1: Simon Pasquier <spasquier@mirantis.com> Verified+2: Jenkins Submitted-by: Jenkins Submitted-at: Wed, 29 Mar 2017 12:33:32 +0000 Reviewed-on: https://review.openstack.org/451238 Project: openstack/fuel-plugin-lma-collector Branch: refs/heads/master
-rw-r--r--deployment_scripts/puppet/manifests/Gemfile2
-rw-r--r--deployment_scripts/puppet/modules/fuel_lma_collector/Gemfile2
-rw-r--r--deployment_scripts/puppet/modules/heka/Gemfile2
-rw-r--r--deployment_scripts/puppet/modules/lma_collector/Gemfile2
4 files changed, 8 insertions, 0 deletions
diff --git a/deployment_scripts/puppet/manifests/Gemfile b/deployment_scripts/puppet/manifests/Gemfile
index e4105df..7d2ce4e 100644
--- a/deployment_scripts/puppet/manifests/Gemfile
+++ b/deployment_scripts/puppet/manifests/Gemfile
@@ -18,4 +18,6 @@ group :development, :test do
18 gem "puppet", ENV['PUPPET_VERSION'] || '~> 3.4.0' 18 gem "puppet", ENV['PUPPET_VERSION'] || '~> 3.4.0'
19 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0 19 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
20 gem 'puppetlabs_spec_helper', '~> 1.1.1' 20 gem 'puppetlabs_spec_helper', '~> 1.1.1'
21 # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
22 gem 'puppet-lint', '~> 2.1.0'
21end 23end
diff --git a/deployment_scripts/puppet/modules/fuel_lma_collector/Gemfile b/deployment_scripts/puppet/modules/fuel_lma_collector/Gemfile
index 585f6b7..e8a2c49 100644
--- a/deployment_scripts/puppet/modules/fuel_lma_collector/Gemfile
+++ b/deployment_scripts/puppet/modules/fuel_lma_collector/Gemfile
@@ -21,5 +21,7 @@ group :development, :test do
21 gem 'rspec-puppet-facts' 21 gem 'rspec-puppet-facts'
22 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0 22 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
23 gem 'puppetlabs_spec_helper', '~> 1.1.1' 23 gem 'puppetlabs_spec_helper', '~> 1.1.1'
24 # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
25 gem 'puppet-lint', '~> 2.1.0'
24 gem 'metadata-json-lint' 26 gem 'metadata-json-lint'
25end 27end
diff --git a/deployment_scripts/puppet/modules/heka/Gemfile b/deployment_scripts/puppet/modules/heka/Gemfile
index 585f6b7..e8a2c49 100644
--- a/deployment_scripts/puppet/modules/heka/Gemfile
+++ b/deployment_scripts/puppet/modules/heka/Gemfile
@@ -21,5 +21,7 @@ group :development, :test do
21 gem 'rspec-puppet-facts' 21 gem 'rspec-puppet-facts'
22 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0 22 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
23 gem 'puppetlabs_spec_helper', '~> 1.1.1' 23 gem 'puppetlabs_spec_helper', '~> 1.1.1'
24 # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
25 gem 'puppet-lint', '~> 2.1.0'
24 gem 'metadata-json-lint' 26 gem 'metadata-json-lint'
25end 27end
diff --git a/deployment_scripts/puppet/modules/lma_collector/Gemfile b/deployment_scripts/puppet/modules/lma_collector/Gemfile
index 585f6b7..e8a2c49 100644
--- a/deployment_scripts/puppet/modules/lma_collector/Gemfile
+++ b/deployment_scripts/puppet/modules/lma_collector/Gemfile
@@ -21,5 +21,7 @@ group :development, :test do
21 gem 'rspec-puppet-facts' 21 gem 'rspec-puppet-facts'
22 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0 22 # Newer puppetlabs_spec_helper depends on rubocop-rspec that requires ruby >= 2.2.0
23 gem 'puppetlabs_spec_helper', '~> 1.1.1' 23 gem 'puppetlabs_spec_helper', '~> 1.1.1'
24 # puppet-lint >= 2.2.0 don't support Puppet 3.x anymore
25 gem 'puppet-lint', '~> 2.1.0'
24 gem 'metadata-json-lint' 26 gem 'metadata-json-lint'
25end 27end