summaryrefslogtreecommitdiff
path: root/README.md
blob: ab77e9769ef4b6842aa4182c5f57721b97e48666 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
Sensu plugin for Fuel
=================================

Overview
--------

Sensu plugin for Fuel extends Mirantis OpenStack functionality by adding
Sensu monitoring. It can be deployed on hosts with Stacklight plugins roles.
Sensu plugin is 100% hot-pluggable.


Compatible Fuel versions
------------------------

9.0


User Guide
----------

1. Create an environment or open existing. In case of new environment select new nodes
   with LMA Stacklights roles
2. Enable the plugin on the Settings/Other tab of the Fuel web UI and fill in form
    fields:
   * in development

3. Deploy the environment.


Installation Guide
==================

Sensu Plugin for Fuel installation
----------------------------------------------

To install Sensu plugin, follow these steps:

1. Download the plugin
    git clone https://github.com/openstack/fuel-plugin-sensu

2. Copy the plugin on already installed Fuel Master node; ssh can be used for
    that. If you do not have the Fuel Master node yet, see
    [Quick Start Guide](https://software.mirantis.com/quick-start/):

        # scp fuel-plugin-sensu-0.1.1-1.noarch.rpm root@<Fuel_master_ip>:/tmp

3. Log into the Fuel Master node. Install the plugin:

        # cd /tmp
        # fuel plugins --install fuel-plugin-sensu-0.1.1-1.noarch.rpm

4. Check if the plugin was installed successfully:

        # fuel plugins
        id | name                            | version | package_version
        ---|---------------------------------|---------|----------------
        1  | fuel-plugin-sensu   | 0.1.1  | 4.0.0


Requirements
------------

| Requirement                      | Version/Comment |
|:---------------------------------|:----------------|
| Mirantis OpenStack compatibility | 9.0             |


Limitations
-----------

This plugin can be used only with Stacklight LMA nodes