summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2017-06-15 16:22:56 +0000
committerOpenStack Proposal Bot <openstack-infra@lists.openstack.org>2017-06-15 16:22:56 +0000
commit74ed580ea1507e9bfa04f6a6f00900e5c63f13ae (patch)
treed8c270946206465f3b83352b1ade3abeb50cca9c
parent309162a58395e20e5c5faffcfdcdbb0642882768 (diff)
Updated from global requirements
Notes
Notes (review): Code-Review+1: Sean McGinnis <sean.mcginnis@gmail.com> Code-Review+2: Erno Kuvaja <jokke@usr.fi> Workflow+1: Erno Kuvaja <jokke@usr.fi> Verified+2: Jenkins Submitted-by: Jenkins Submitted-at: Mon, 19 Jun 2017 19:28:02 +0000 Reviewed-on: https://review.openstack.org/460745 Project: openstack/glance_store Branch: refs/heads/master
-rw-r--r--requirements.txt10
-rw-r--r--setup.cfg6
-rw-r--r--test-requirements.txt6
3 files changed, 11 insertions, 11 deletions
diff --git a/requirements.txt b/requirements.txt
index 1dedf29..ce558c1 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,18 +1,18 @@
1# The order of packages is significant, because pip processes them in the order 1# The order of packages is significant, because pip processes them in the order
2# of appearance. Changing the order has an impact on the overall integration 2# of appearance. Changing the order has an impact on the overall integration
3# process, which may cause wedges in the gate later. 3# process, which may cause wedges in the gate later.
4oslo.config>=3.22.0 # Apache-2.0 4oslo.config!=4.3.0,!=4.4.0,>=4.0.0 # Apache-2.0
5oslo.i18n>=2.1.0 # Apache-2.0 5oslo.i18n!=3.15.2,>=2.1.0 # Apache-2.0
6oslo.serialization>=1.10.0 # Apache-2.0 6oslo.serialization>=1.10.0 # Apache-2.0
7oslo.utils>=3.20.0 # Apache-2.0 7oslo.utils>=3.20.0 # Apache-2.0
8oslo.concurrency>=3.8.0 # Apache-2.0 8oslo.concurrency>=3.8.0 # Apache-2.0
9stevedore>=1.20.0 # Apache-2.0 9stevedore>=1.20.0 # Apache-2.0
10enum34;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD 10enum34;python_version=='2.7' or python_version=='2.6' or python_version=='3.3' # BSD
11 11
12eventlet!=0.18.3,>=0.18.2 # MIT 12eventlet!=0.18.3,!=0.20.1,<0.21.0,>=0.18.2 # MIT
13six>=1.9.0 # MIT 13six>=1.9.0 # MIT
14 14
15jsonschema!=2.5.0,<3.0.0,>=2.0.0 # MIT 15jsonschema!=2.5.0,<3.0.0,>=2.0.0 # MIT
16keystoneauth1>=2.18.0 # Apache-2.0 16keystoneauth1>=2.21.0 # Apache-2.0
17python-keystoneclient>=3.8.0 # Apache-2.0 17python-keystoneclient>=3.8.0 # Apache-2.0
18requests!=2.12.2,!=2.13.0,>=2.10.0 # Apache-2.0 18requests>=2.14.2 # Apache-2.0
diff --git a/setup.cfg b/setup.cfg
index 281fe63..0690aa1 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -59,10 +59,10 @@ swift =
59 httplib2>=0.7.5 # MIT 59 httplib2>=0.7.5 # MIT
60 python-swiftclient>=3.2.0 # Apache-2.0 60 python-swiftclient>=3.2.0 # Apache-2.0
61cinder = 61cinder =
62 python-cinderclient>=2.0.1 # Apache-2.0 62 python-cinderclient>=2.1.0 # Apache-2.0
63 os-brick>=1.11.0 # Apache-2.0 63 os-brick>=1.13.1 # Apache-2.0
64 oslo.rootwrap>=5.0.0 # Apache-2.0 64 oslo.rootwrap>=5.0.0 # Apache-2.0
65 oslo.privsep>=1.9.0 # Apache-2.0 65 oslo.privsep!=1.17.0,>=1.9.0 # Apache-2.0
66 66
67[build_sphinx] 67[build_sphinx]
68source-dir = doc/source 68source-dir = doc/source
diff --git a/test-requirements.txt b/test-requirements.txt
index cc2dbf4..cedb6c1 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -8,7 +8,7 @@ hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
8mock>=2.0 # BSD 8mock>=2.0 # BSD
9 9
10# Unit testing 10# Unit testing
11coverage>=4.0 # Apache-2.0 11coverage!=4.4,>=4.0 # Apache-2.0
12fixtures>=3.0.0 # Apache-2.0/BSD 12fixtures>=3.0.0 # Apache-2.0/BSD
13python-subunit>=0.0.18 # Apache-2.0/BSD 13python-subunit>=0.0.18 # Apache-2.0/BSD
14requests-mock>=1.1 # Apache-2.0 14requests-mock>=1.1 # Apache-2.0
@@ -20,6 +20,6 @@ os-testr>=0.8.0 # Apache-2.0
20bandit>=1.1.0 # Apache-2.0 20bandit>=1.1.0 # Apache-2.0
21 21
22# this is required for the docs build jobs 22# this is required for the docs build jobs
23sphinx>=1.5.1 # BSD 23sphinx!=1.6.1,>=1.5.1 # BSD
24oslosphinx>=4.7.0 # Apache-2.0 24oslosphinx>=4.7.0 # Apache-2.0
25reno>=1.8.0 # Apache-2.0 25reno!=2.3.1,>=1.8.0 # Apache-2.0