summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFellype Cavalcante <fellypefca@lsd.ufcg.edu.br>2017-05-29 13:44:49 -0300
committerFellype Cavalcante <fellypefca@lsd.ufcg.edu.br>2017-05-30 11:57:03 -0300
commit07cff23aab22d3265272d460ecb126407a661b75 (patch)
tree8bbea5782dd5bd9c73e7179909d1ec407dce085a
parentebe708924c3559fb60be353ec8a4c56609320ad4 (diff)
python-oneviewclient version bump
Updating the minimum version of python-oneviewclient in stable/newton. We noticed that the CI server have been using the latest version of python-oneviewclient and altered our jobs to use the minimum version specified at driver-requirements. When attempting to run stable/newton with python-oneviewclient==2.0.2 we noticed that the driver never worked with this version. The minimum required version for stable/newton is now 2.5.1. Closes-Bug: 1694297 Change-Id: Id396e529de3eba306421dac91e205f4b6a52573f
Notes
Notes (review): Code-Review+2: Doug Hellmann <doug@doughellmann.com> Code-Review+2: Dmitry Tantsur <divius.inside@gmail.com> Code-Review+1: Tuan Luong-Anh <tuanla@vn.fujitsu.com> Workflow+1: Dmitry Tantsur <divius.inside@gmail.com> Verified+2: Jenkins Submitted-by: Jenkins Submitted-at: Wed, 31 May 2017 14:55:12 +0000 Reviewed-on: https://review.openstack.org/468925 Project: openstack/ironic Branch: refs/heads/stable/newton
-rw-r--r--driver-requirements.txt2
-rw-r--r--releasenotes/notes/client-version-6deeb64d489bebc3.yaml6
2 files changed, 7 insertions, 1 deletions
diff --git a/driver-requirements.txt b/driver-requirements.txt
index 711c337..b5a418f 100644
--- a/driver-requirements.txt
+++ b/driver-requirements.txt
@@ -8,7 +8,7 @@ proliantutils>=2.1.11
8pyghmi>=0.8.0 8pyghmi>=0.8.0
9pysnmp 9pysnmp
10python-ironic-inspector-client>=1.5.0 10python-ironic-inspector-client>=1.5.0
11python-oneviewclient<3.0.0,>=2.0.2 11python-oneviewclient<3.0.0,>=2.5.1
12python-scciclient>=0.4.0 12python-scciclient>=0.4.0
13python-seamicroclient>=0.4.0 13python-seamicroclient>=0.4.0
14UcsSdk==0.8.2.2 14UcsSdk==0.8.2.2
diff --git a/releasenotes/notes/client-version-6deeb64d489bebc3.yaml b/releasenotes/notes/client-version-6deeb64d489bebc3.yaml
new file mode 100644
index 0000000..7cdc1a3
--- /dev/null
+++ b/releasenotes/notes/client-version-6deeb64d489bebc3.yaml
@@ -0,0 +1,6 @@
1fixes:
2 - Updating the python-oneviewclient minimum version to 2.5.1 on
3 driver-requirements.txt. The minimum version that was in the requirements
4 was 2.0.2, and is very outdated, causing the driver to not work for this
5 version. With this change, the new minimal version works for the driver,
6 making the CI for stable/newton also work.