summaryrefslogtreecommitdiff
path: root/README.rst
diff options
context:
space:
mode:
authorIan Wienand <iwienand@redhat.com>2018-07-17 10:36:01 +1000
committerTony Breeds <tony@bakeyournoodle.com>2018-07-18 09:27:01 +1000
commit110732672309e9c4e4d817cc4025314c04e927a0 (patch)
treef9174c807978ab6587a4cda40a99dd0b6e7b6f30 /README.rst
parentb79952af2a3a07a2ab38ed292cb0eef7febe2258 (diff)
Update pylint to 1.7.6, uncap networkxHEAD2.16.0master
This review squashes: Iac9afc7766d3640815dc20cfd6de1245d36a09cc Ie894b5801bd7b3815432882cd626941e89d9f9a1 We need to do this as we can't fix pylint without networkx as that failes requirements-chak due to us having a cap on networkx and we can't uncap networkx as part of tripleo-buildimage installs without constratints which gets us 2.1 and DIB desn't support 2.x This is the commit message Iac9afc7766d3640815dc20cfd6de1245d36a09cc --- One of the pylint dependencies has updated to be python3 only; this version of pylint correctly caps things so it still works with python2. This also exposes that we need to uncap networkx due to I34045f87ca19c2f184b040f4d89347374cce518b. We should remain on version 1 for now thanks to upper-constraints, but we need to maintain the lower-constraint. --- This is the commit message Ie894b5801bd7b3815432882cd626941e89d9f9a1 --- Support different versions of networkx Since the entry of networkx 2.0 nodes has a different behaviour. Checking if dg.nodes is iterable is enough to add compatibility for new/older versions. --- Change-Id: I82dc61fac6c156a4f0d574290c7632077aa53195
Notes
Notes (review): Code-Review+2: Ian Wienand <iwienand@redhat.com> Code-Review+2: Tony Breeds <tony@bakeyournoodle.com> Workflow+1: Tony Breeds <tony@bakeyournoodle.com> Verified+2: Zuul Submitted-by: Zuul Submitted-at: Wed, 18 Jul 2018 04:46:07 +0000 Reviewed-on: https://review.openstack.org/583413 Project: openstack/diskimage-builder Branch: refs/heads/master
Diffstat (limited to 'README.rst')
0 files changed, 0 insertions, 0 deletions