summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Jaeger <aj@suse.com>2018-01-31 09:04:59 +0100
committerAndreas Jaeger <aj@suse.com>2018-02-02 07:53:18 +0100
commitad804626c464d176c350f5e9232da22ca900dff1 (patch)
tree60229f1a7fcf2d40a346e4c96abadd95d6002d2b
parentb414dff1b476c9c7389daa337e8c70eaf7b3a2b5 (diff)
Update requirements manually1.5.3
The global requirments sync for this repo fails since it lists packages that are not in the global list. Manually sync requirements. Failure log from requirements sync: http://logs.openstack.org/d8/d89aad257d43fe02e42e44b2a0187dbd9f505c36/post/propose-update-requirements/15a7777/job-output.txt.gz#_2018-01-31_06_51_56_655451 Errors are: 'discover' is not in global-requirements.txt or blacklist.txt 'dpath' is not in global-requirements.txt or blacklist.txt 'salt' is not in global-requirements.txt or blacklist.txt 'yamllint' is not in global-requirements.txt or blacklist.txt Change-Id: Ifbd174d568b0cae5225faa6e25b1bc5fc4774e6e
Notes
Notes (review): Code-Review+2: Zane Bitter <zbitter@redhat.com> Workflow+1: Zane Bitter <zbitter@redhat.com> Verified+2: Zuul Submitted-by: Zuul Submitted-at: Fri, 02 Feb 2018 16:11:16 +0000 Reviewed-on: https://review.openstack.org/539447 Project: openstack/heat-agents Branch: refs/heads/master
-rw-r--r--requirements.txt3
-rw-r--r--setup.py15
-rw-r--r--test-requirements.txt35
3 files changed, 35 insertions, 18 deletions
diff --git a/requirements.txt b/requirements.txt
index e69de29..9dbc011 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -0,0 +1,3 @@
1# The order of packages is significant, because pip processes them in the order
2# of appearance. Changing the order has an impact on the overall integration
3# process, which may cause wedges in the gate later.
diff --git a/setup.py b/setup.py
index 93952d8..566d844 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
1#!/usr/bin/env python 1# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
2#
2# Licensed under the Apache License, Version 2.0 (the "License"); 3# Licensed under the Apache License, Version 2.0 (the "License");
3# you may not use this file except in compliance with the License. 4# you may not use this file except in compliance with the License.
4# You may obtain a copy of the License at 5# You may obtain a copy of the License at
@@ -11,8 +12,18 @@
11# implied. 12# implied.
12# See the License for the specific language governing permissions and 13# See the License for the specific language governing permissions and
13# limitations under the License. 14# limitations under the License.
15
16# THIS FILE IS MANAGED BY THE GLOBAL REQUIREMENTS REPO - DO NOT EDIT
14import setuptools 17import setuptools
15 18
19# In python < 2.7.4, a lazy loading of package `pbr` will break
20# setuptools if some other modules registered functions in `atexit`.
21# solution from: http://bugs.python.org/issue15881#msg170215
22try:
23 import multiprocessing # noqa
24except ImportError:
25 pass
26
16setuptools.setup( 27setuptools.setup(
17 setup_requires=['pbr'], 28 setup_requires=['pbr>=2.0.0'],
18 pbr=True) 29 pbr=True)
diff --git a/test-requirements.txt b/test-requirements.txt
index acfaf6a..b35c1ca 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -1,23 +1,26 @@
1coverage>=4.0 # Apache-2.0 1# The order of packages is significant, because pip processes them in the order
2# of appearance. Changing the order has an impact on the overall integration
3# process, which may cause wedges in the gate later.
4coverage!=4.4,>=4.0 # Apache-2.0
2discover 5discover
3dpath>=1.3.2 6dpath>=1.3.2
4fixtures>=3.0.0 # Apache-2.0/BSD 7fixtures>=3.0.0 # Apache-2.0/BSD
5# Hacking already pins down pep8, pyflakes and flake8 8# Hacking already pins down pep8, pyflakes and flake8
6hacking>=0.12.0,!=0.13.0,<0.14 # Apache-2.0 9hacking!=0.13.0,<0.14,>=0.12.0 # Apache-2.0
7mock>=2.0 # BSD 10mock>=2.0.0 # BSD
8openstackdocstheme>=1.11.0 # Apache-2.0 11openstackdocstheme>=1.18.1 # Apache-2.0
9paunch>=1.0.0 # Apache-2.0 12paunch>=1.0.0 # Apache-2.0
10reno>=2.5.0 # Apache-2.0 13reno>=2.5.0 # Apache-2.0
11requests>=2.10.0,!=2.12.2,!=2.13.0 # Apache-2.0 14requests>=2.14.2 # Apache-2.0
12requests-mock>=1.1 # Apache-2.0 15requests-mock>=1.1.0 # Apache-2.0
13salt 16salt
14sphinx>=1.6.2 # BSD 17sphinx!=1.6.6,>=1.6.2 # BSD
15testrepository>=0.0.18 18testrepository>=0.0.18 # Apache-2.0/BSD
16testscenarios>=0.4 19testscenarios>=0.4 # Apache-2.0/BSD
17testtools>=1.4.0 # MIT 20testtools>=2.2.0 # MIT
18yamllint>=1.2.0 21yamllint>=1.2.0
19os-apply-config # Apache-2.0 22os-apply-config>=5.0.0 # Apache-2.0
20 23
21python-heatclient>=1.6.1 # Apache-2.0 24python-heatclient>=1.10.0 # Apache-2.0
22python-keystoneclient>=3.8.0 # Apache-2.0 25python-keystoneclient>=3.8.0 # Apache-2.0
23python-openstackclient>=3.3.0 # Apache-2.0 26python-openstackclient>=3.12.0 # Apache-2.0