summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEduardo Gonzalez <dabarren@gmail.com>2018-08-15 08:46:12 +0200
committerEduardo Gonzalez <dabarren@gmail.com>2018-08-15 08:48:35 +0200
commit8d2e52f72ee00676119e065d6b4e688983d3689a (patch)
treee877ca4c4269e3cc64ced60559f0b8133a26b654
parent8d5c5fa8254df3cd9f9b5574473dbe02c0146e6b (diff)
Add icalendar into requirements
icalendar package is required to karbor-dashboard to work. It is imported and used at https://github.com/openstack/karbor-dashboard/blob/bfcecfee68e43f903c00354bc7fd759dc71c04b1/karbor_dashboard/triggers/utils.py#L18 If package is not included, horizon fails to start, this dependency should be fixed in karbor-dashboard side rather than in deployment tools/packagers. Change-Id: I7eb826ee6f08366f0aa934342e0cdf0eaaa0bae0 Closes-Bug: #1787040
Notes
Notes (review): Code-Review+2: Jiao Pengju <jiaopengju@cmss.chinamobile.com> Code-Review+1: Ivan Kolodyazhny <e0ne@e0ne.info> Workflow+1: Jiao Pengju <jiaopengju@cmss.chinamobile.com> Verified+2: Zuul Submitted-by: Zuul Submitted-at: Mon, 14 Jan 2019 01:11:41 +0000 Reviewed-on: https://review.openstack.org/591923 Project: openstack/karbor-dashboard Branch: refs/heads/master
-rw-r--r--requirements.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/requirements.txt b/requirements.txt
index 4d451d5..28af493 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -14,3 +14,4 @@ django-babel>=0.5.1 # BSD
14django-compressor>=2.0 # MIT 14django-compressor>=2.0 # MIT
15django-pyscss>=2.0.2 # BSD License (2 clause) 15django-pyscss>=2.0.2 # BSD License (2 clause)
16python-karborclient>=0.6.0 # Apache-2.0 16python-karborclient>=0.6.0 # Apache-2.0
17icalendar>=4.0.2 # BSD