summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Philippe Evrard <jean-philippe@evrard.me>2019-03-08 08:44:07 +0100
committerJean-Philippe Evrard <jean-philippe@evrard.me>2019-03-08 08:44:55 +0100
commit1dbc250a22d6f2e42c4a33f6f44de6eac3e5655a (patch)
tree22669ef61550fa4738b84198541ae5f9125c8858
parent329e83a6e3b9a9c28602e38d404ba2c89bf0fc94 (diff)
Revert "For OpenSUSE Leap, use more recent version of zVMCloudConnector"
Now that requirements patch has merged, we can remove this hack. This reverts commit 329e83a6e3b9a9c28602e38d404ba2c89bf0fc94. Depends-On: https://review.openstack.org/#/c/641738/ Change-Id: I2b3f6fc95df6e15077d280436ca5ea06715b3c5a
Notes
Notes (review): Code-Review+2: Chris Hoge <chris@openstack.org> Workflow+1: Chris Hoge <chris@openstack.org> Verified+2: Zuul Submitted-by: Zuul Submitted-at: Mon, 18 Mar 2019 16:08:32 +0000 Reviewed-on: https://review.openstack.org/641957 Project: openstack/loci Branch: refs/heads/master
-rwxr-xr-xscripts/requirements.sh9
1 files changed, 0 insertions, 9 deletions
diff --git a/scripts/requirements.sh b/scripts/requirements.sh
index 9d53a1a..8c380f4 100755
--- a/scripts/requirements.sh
+++ b/scripts/requirements.sh
@@ -20,15 +20,6 @@ fi
20# anymore 20# anymore
21sed -i '/python-qpid-proton===0.14.0/d' /upper-constraints.txt 21sed -i '/python-qpid-proton===0.14.0/d' /upper-constraints.txt
22 22
23# zVMCloudConnector for queens requires python<=3.5, but Leap has already python3.6
24case ${distro} in
25 opensuse|opensuse-leap|opensuse-tumbleweed|sles)
26 if [[ "${PYTHON3}" != "no" ]] && [[ "${PROJECT_REF}" == "stable/queens" ]]; then
27 sed -i 's/zVMCloudConnector===0.3.5/zVMCloudConnector===1.0.0/' /upper-constraints.txt
28 fi
29 ;;
30esac
31
32if [[ "${PYTHON3}" == "no" ]]; then 23if [[ "${PYTHON3}" == "no" ]]; then
33 ignore_wheels=py2 24 ignore_wheels=py2
34else 25else