summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Urdin <tobias.urdin@binero.se>2019-02-08 12:09:47 +0100
committerTobias Urdin <tobias.urdin@binero.se>2019-02-08 12:09:47 +0100
commit6f143c16addd23c26e6f704e8cdc94f160484068 (patch)
tree3110afb787f45b2925be0b4638b91684ead16c6c
parent96e5483986ca5d22e2cb997a5f7250d39cc87325 (diff)
Use puppet 4 compatible mysql functions
These was introduced in 6.0.0 and is required to support later version of puppetlabs-mysql. Change-Id: I07066787f021c1985a4708a9dc8c11c2d9ad1ec5
Notes
Notes (review): Code-Review+2: Emilien Macchi <emilien@redhat.com> Code-Review+2: Alex Schultz <aschultz@redhat.com> Workflow+1: Alex Schultz <aschultz@redhat.com> Verified+2: Zuul Submitted-by: Zuul Submitted-at: Mon, 11 Feb 2019 20:57:32 +0000 Reviewed-on: https://review.openstack.org/635792 Project: openstack/puppet-glare Branch: refs/heads/master
-rw-r--r--manifests/db/mysql.pp2
-rw-r--r--metadata.json4
-rw-r--r--releasenotes/notes/puppet4-mysql-func-8ced1e1b5d17fa28.yaml4
3 files changed, 9 insertions, 1 deletions
diff --git a/manifests/db/mysql.pp b/manifests/db/mysql.pp
index bddad7e..cbc8c8a 100644
--- a/manifests/db/mysql.pp
+++ b/manifests/db/mysql.pp
@@ -49,7 +49,7 @@ class glare::db::mysql(
49 49
50 ::openstacklib::db::mysql { 'glare': 50 ::openstacklib::db::mysql { 'glare':
51 user => $user, 51 user => $user,
52 password_hash => mysql_password($password), 52 password_hash => mysql::password($password),
53 dbname => $dbname, 53 dbname => $dbname,
54 host => $host, 54 host => $host,
55 charset => $charset, 55 charset => $charset,
diff --git a/metadata.json b/metadata.json
index 79849e4..6b26413 100644
--- a/metadata.json
+++ b/metadata.json
@@ -39,6 +39,10 @@
39 "version_requirement": ">= 5.0.0 <6.0.0" 39 "version_requirement": ">= 5.0.0 <6.0.0"
40 }, 40 },
41 { 41 {
42 "name": "puppetlabs/mysql",
43 "version_requirement": ">=6.0.0 <9.0.0"
44 },
45 {
42 "name": "openstack/openstacklib", 46 "name": "openstack/openstacklib",
43 "version_requirement": ">=14.2.0 <15.0.0" 47 "version_requirement": ">=14.2.0 <15.0.0"
44 }, 48 },
diff --git a/releasenotes/notes/puppet4-mysql-func-8ced1e1b5d17fa28.yaml b/releasenotes/notes/puppet4-mysql-func-8ced1e1b5d17fa28.yaml
new file mode 100644
index 0000000..9db533e
--- /dev/null
+++ b/releasenotes/notes/puppet4-mysql-func-8ced1e1b5d17fa28.yaml
@@ -0,0 +1,4 @@
1---
2upgrade:
3 - |
4 This module now requires a puppetlabs-mysql version >= 6.0.0